AnsweredAssumed Answered

Problems with adding LWIP to an MCUXpresso Project

Question asked by Andrew Walsh on Nov 4, 2019
Latest reply on Dec 3, 2019 by Victor Jimenez

Hello,

 

We have an existing project, running on a IMXRT1052DVL6B on our own PCB (using IDE v10.3.1 build 2233 and SDK v2.5.0). I've tried importing LWIP from the MCUXpresso SDK into this project, because we now have a need for TCP/IP communications.

 

First, I could not select LWIP in the "Manage SDK Components" dialog. So, I then tried to copying the LWIP folder manually into our source folder (refreshing the project in MCUXpresso and manually adding the include paths. When I attempted to build the project, this resulted in some surprising errors, which I don't currently understand (please see the attached, copied from the MCUXpresso build output).

 

I then did some more research, and found, in this forum, that not being able to import LWIP from "Manage SDK Components" is a known problem with the 2.5.0 SDK. So I upgraded to v2.5.1 and I found I *could* import LWIP using the dialog, but it still failed to build in the same way.

 

Any ideas as to what could be happening here? And what we could do to work around it?

 

Best regards,

 

Andrew.

Outcomes