AnsweredAssumed Answered

Problem factory resetting S32K144

Question asked by Jonas Garsten on Oct 30, 2019
Latest reply on Nov 5, 2019 by Jorge Antonio Alcala Vazquez

Hi, 

 

I have tried to factory reset my S32K144 board after changing the NVM memory (writing 0 to FNMC) on it by setting

 

• pin RSTN is held LOW
• CANH is pulled up to VBAT
• CANL is pulled down to GND

 

on battery power up (as I turn on the power supply) as it says in the UJA1169 data sheet. The debugger has always been disconnected. The configuration used to achieve this is:

 

RSTN is held low by connecting TP24 to GND pin on board.

CANH is pulled high by connecting it to the positive pole on the same power supply powering the board.

CANL is pulled down by connecting it to the negative pole on the same power supply powering the board.

 

I have also tried to hold RSTN low by holding the reset button or supplying the reset pin on the board with 3.3V. 

 

During power up I have measured on pin PTE4 as it is connected to RXD to see if it is forced high. I measured 5V but not the falling edge indicating that the process was over.

 

I have confirmed that the factory reset have failed by reading register 0x70 on the sbc and the value returned is 0x4 telling me that the memory has only been written to once and that NVMPS is 0 (should be 1).

 

Any help is appreciated. 

Outcomes