AnsweredAssumed Answered

Usb not acting as otg in imx6slevk

Question asked by Sujay S on Oct 22, 2019
Latest reply on Oct 24, 2019 by Sujay S

I'm using an imx6slevk board with yocto bsp, after flashing the images.

There is a USB b type port which I use to connect to my linux PC and I use:

lsusb
for which I get:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc. Logilink CR0012
Bus 001 Device 003: ID 046d:c31d Logitech, Inc. Media Keyboard K200
Bus 001 Device 005: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 17ef:602e Lenovo
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

now I changed from boot mode to flash mode and did the same and I get

 

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 05e3:0745 Genesys Logic, Inc. Logilink CR0012
Bus 001 Device 025: ID 15a2:0063 Freescale Semiconductor, Inc.
Bus 001 Device 003: ID 046d:c31d Logitech, Inc. Media Keyboard K200
Bus 001 Device 005: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 17ef:602e Lenovo
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


as you can see an extra line is present

 

I would like the board to be detected even in boot mode so that I can transfer files to my board.

 

I've tried to enable USB_CDC in menuconfig but it has no effect on the output what should I enable for the board to be detected by linux PC using lsusb?

 

I've attached  the dmsg of the board.

this is my dts for usb

 

&usbotg1 {
 vbus-supply = <&reg_usb_otg1_vbus>;
 pinctrl-names = "default";
 pinctrl-0 = <&pinctrl_usbotg1>;
disable-over-current;
 srp-disable;
hnp-disable;
adp-disable;
status = "okay";
};

 

 &usbotg2 {
 vbus-supply = <&reg_usb_otg2_vbus>;
 dr_mode = "host";
 disable-over-current;
 status = "okay";
 };

Attachments

Outcomes