AnsweredAssumed Answered

Linux Redlink server wont open

Question asked by Robert Morrison on Oct 5, 2019
Latest reply on Oct 6, 2019 by Robert Morrison

I have to move from Win to a linux Mint workstation, and successfully installed LPCXpress there.  I brought over all LPC4357 project code and was able to successfully build.  However, I cannot connect to my emulator (Keil ULink-ME).  I see the device in the linux /dev directory (hidraw5, permissions rw for all users) but starting the Redlink server never connects to it (cannot open server).  I viewed  the redlink console and manually restarted it, but doing any operation such as run closes the server with an error dialog box with a long list of errors--starting with cannot open server.  This has all worked fine under the windows environment--why can't the linux version find the emulator?  I set both JTAG and SWD modes, and am using the LinkServer emulator option.  I read the lpcexpresso user manual and online, I tried a bunch of online help ideas, but I am completely shut down trying to wake up the emulator.

Outcomes