AnsweredAssumed Answered

i.mx6qp Custom board - Ethernet PHY issue

Question asked by sahanashreee . on Oct 4, 2019
Latest reply on Oct 4, 2019 by igorpadykov

We have built a custom board with i.MX6QP based on NXP i.MX6QP-SABESD hardware.
Currently we are checking the Ethernet on u-boot and we are seeing the error as "Error: ethernet@02188000 address not set. No ethernet found"Please see the complete boot-up log below -
------------------------------------------

U-Boot 2017.03-nxp/imx_v2017.03_4.9.11_1.0.0_ga+ga2fea67 (Feb 15 2019 - 11:03:24 +0530)

CPU: Freescale i.MX6QP rev1.0 996 MHz (running at 792 MHz)
CPU: Automotive temperature grade (-40C to 125C) at 43C
Reset cause: POR
Model: Freescale i.MX6 Quad Plus SABRE Smart Device Board
Board: MX6-SabreSD
DRAM: 1 GiB
PMIC: PFUZE100! DEV_ID=0x10 REV_ID=0x21
MMC: FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2
*** Warning - bad CRC, using default environment

No panel detected: default to Hannstar-XGA
Display: Hannstar-XGA (1024x768)
In: serial
Out: serial
Err: serial
switch to partitions #0, OK
mmc1 is current device
Net:
Error: ethernet@02188000 address not set.
No ethernet found.
Normal Boot
Hit any key to stop autoboot: 3 2 1 0
switch to partitions #0, OK
mmc1 is current device
** Invalid partition 1 **
** Invalid partition 1 **
Booting from net ...

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.
No ethernet found.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.

Error: ethernet@02188000 address not set.
No ethernet found.

Error: ethernet@02188000 address not set.
Bad Linux ARM zImage magic!


------------------------------------------

The custom board uses the exact same PHY AR8031 used on the i.MXQP SABESD hardware.Has anyone come across this issue? Should we do any one time setup of the eth interface ?
Please help me with inputs on what can be possible issue. Thanks in advance.Kindly let me know if any details are needed.

Outcomes