AnsweredAssumed Answered

How do I get my CodeWarrior USB TAP to communicate

Question asked by Eric Burgoyne on Oct 1, 2019
Latest reply on Oct 14, 2019 by Pavel Chubakov

The CodeWarrior is new to me.

I have a new T2081RDB unit, which boots up with factory installed images.
I have removed the cover and connected a CodeWarrior USB TAP to the T2080_COP 16-pin connector.
The USB TAP is hosted on a PC running VMware Workstation 12 Pro, loaded with Ubuntu 14.04.3.
On this VMware Workstation I have loaded CodeWarrior Development Studio for Power Architecture v10.5.1 - Linux.tar
by un-tar'ing and running (as root) ./setuplinux -c

My goal is to simply read the T2080 SCRATCHRW2 register.

Using the serially connected console, I inturrupted the boot processes, receiving a u-boot prompt.
I connect the TAP to the host PC.
The LED's on the TAP: TX/RX blinks red 1Hz for a few seconds, then blinks red at 5Hz for about a second, then green at 1Hz continually.
RUN/PAUSE, over the same time period, one initial red blink, off until the TX/RX blinks green, one green blink then remains off.

Looking at ccs/drivers/readme files and searching for help on-line it appears that the USB TAP drivers may need to be installed manually.
As root, I copied 00-usbtab.rules to /etc/udev/rules.d/. (I also tried /lib/udev/rules.d/.)
I copied usbtap to /etc/udev/.
I executed the commnad: udevcontrol reload_rules.
I also tried re-booting linux.
Nothing seems to change the TAP LEDs from TX/RX blinking green 1Hz, RUN/PAUSE off.

I start up the CodeWarrior Development Studio IDE (CodeWarrior_PA_10.5.1/eclipse/cwide)
File>New>CodeWarrior Bareboard Project Wizard
Name: etb2
Processor: T2080
Project Output: Application
Board: T2080RDB-PCIe
Launch: Connect (Default)
Connection Type: CodeWarrior TAP (Over USB)
Language: C
Build Tools Architecture: 32 bit
Toolchain: GCC AEABI e6500
FloatingPoint: Hardware
Processing Model: AMP (One project per core)
Core index: Core 0

Attempt to run this application under debug by selecting: etb2-core00_RAM_T2080_Connect[CodeWarrior]
After the build completes I get a pop-up
Problem Occurred
Launching etb2-core00_RAM_T2080_Connect has encountered a problem.
Would you like to export diagnostic information and send it to Freescale?
Error launching etb2-core00_RAM_T2080_Connect
Details>> CCSProtocolPlugin: Could not connect to the probe (or other debug link)
[CCS last error: CC config string is invalid]
Export Diagnostics selected. (201910011218_DiagnosticInfo.zip)

I start up the /opt/Freescale/CodeWarrior_PA_10.5.1/PA/ccs/bin/ccs (CodeWarrior Connection Server command line app.
Interp>Show Last Error:
unknown option "-state"
while executing
"$menu entrycget $1 -state"
Searching through source code and help files, it appears that "-state" option is only for ccs running on windows?
On the ccs command-line I enter: findcc utaps
USB TAP Serial Numbers:
10261782
(which does match my TAP)

Outcomes