AnsweredAssumed Answered

i.MX8 support for gstreamer-imx

Question asked by tadaharu yamazaki on Sep 25, 2019
Latest reply on Sep 26, 2019 by tadaharu yamazaki

I am trying to use gstreamer with i.MX8mmevk.
When I created yocto image and tried to add gstreamer-imx, the following error occurred and the build failed.

 

Parsing recipes: 100% |##########################################| Time: 0:05:04
Parsing of 2562 .bb files complete (0 cached, 2562 parsed). 3483 targets, 223 skipped, 8 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'gstreamer1.0-plugins-imx' (but /data/imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/dynamic-layers/qt5-layer/recipes-fsl/images/fsl-image-qt5-validation-imx.bb RDEPENDS on or otherwise requires it)
gstreamer1.0-plugins-imx was skipped: incompatible with machine imx8mmevk (not in COMPATIBLE_MACHINE)
NOTE: Runtime target 'gstreamer1.0-plugins-imx' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['gstreamer1.0-plugins-imx']
ERROR: Required build target 'fsl-image-qt5-validation-imx' has no buildable providers.
Missing or unbuildable dependency chain was: ['fsl-image-qt5-validation-imx', 'gstreamer1.0-plugins-imx']

 

So I realize can't build using gstreamer-imx with i.MX8mmevk.

 

Is there a way to use gstreamer-imx with i.MX8mmevk ?

Also, when will gstreamer1.0-plugins-imx_git.bb be compatible with i.MX8 ?

Outcomes