Ruben Valls Blasco

Codewarrior crashes when trying to open any menu item on linux

Discussion created by Ruben Valls Blasco on Mar 1, 2009
Latest reply on Jun 9, 2009 by jun gu

Hi everyone!

I have recently installed Codewarrior on my laptop, using Fedora Core 10 but I can't do anything with it. Everytime I try to open some file from the File/New or File/Open, the program crashes with the following output:

 

 


CodeWarrior_IDE: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

Allocated Threads :
ThreadID: 100 (1900976) Ready

Yielding Threads :
None

IDE Version: 5.9.0 Build 2482 has crashed.
Fatal error (SIGABRT) caught in Process 3335 Thread 1900976

Crash dump written to /home/lopital/.CodeWarrior/Preferences/Metrowerks/CodeWarrior_IDE.20090301.171441A.linux.dump

Exiting...
Aborted

 


I'm using Codewarrior for Coldfire V 5.9.0, and I have tried it on Fedora Core 10 and Ubuntu 8.10, and in both OS I have the same error.

 

Searching the forum I have seen that "maybe" in Fedora Core 3 (http://forums.freescale.com/freescale/board/message?board.id=CWCOMM&message.id=6230&query.id=108102#M6230) and in Ubuntu 7 (http://forums.freescale.com/freescale/board/message?board.id=CWCFCOMM&message.id=1217&query.id=108190#M1217) it works.

 

My question is: Codewarrior does not work in Fedora Core 10 or Ubuntu 8.10 or I am doing something bad? If it works in either FC10 or Ubuntu 8.10, please, can someone tell me step by step how to solve it? I prefer Ubuntu 8.10, but if it can't be, then FC10 is good also.

 

Thanks in advance,

Ruben

 

Message Edited by RValls on 2009-03-01 04:45 PM

Outcomes