AnsweredAssumed Answered

PPP connection failed in yocto

Question asked by fu qiang on Sep 3, 2019
Latest reply on Sep 25, 2019 by fu qiang

Currently, the yocto system needs to be run on imx6q, which needs to support 4g function and use the Quectel ec20 module. When dialing with PPPD, no matter how you modify it, it fails.

The module validates properly and the other attempt to integrate wvdial fails, both of which are successful on debian.

Is there any success at yocto? Or any idea. Thank you

Here is the dial script

====================================

debug

nodetach

/dev/ttyUSB2

115200

usepeerdns

noauth

local

novj

novjccomp

noccp

defaultroute

user "cmnet"

0.0.0.0:0.0.0.0

refuse-chap
refuse-mschap
refuse-mschap-v2

connect '/usr/bin/chat -s -v -f /etc/ppp/connect'

======================================

TIMEOUT 5

ABORT 'NO CARRIER'

ABORT 'ERROR'

ABORT 'NODIALTONE'

ABORT 'BUSY'

ABORT 'NO ANSWER'

'' \rAT

OK \rATZ

OK \rAT+CGDCONT=1,"IP","3GNET",,0,0

OK-AT-OK ATDT*99#

CONNECT \d\c

==================================================

result 

root@imx6qsabresd:~# pppd call wcdma &
[1] 702
root@imx6qsabresd:~# timeout set to 5 seconds
abort on (NO CARRIER)
abort on (ERROR)
abort on (NODIALTONE)
abort on (BUSY)
abort on (NO ANSWER)
send (^MAT^M)
expect (OK)
AT^M^M
OK
-- got it

send (^MATZ^M)
expect (OK)
^M
ATZ^M^M
OK
-- got it

send (^MAT+CGDCONT=1,"IP","3GNET",,0,0^M)
expect (OK)
^M
AT+CGDCONT=1,"IP","3GNET",,0,0^M^M
OK
-- got it

send (ATDT*99#^M)
expect (CONNECT)
^M
ATDT*99#^M^M
CONNECT
-- got it

send (\d)
Script /usr/bin/chat -s -v -f /etc/ppp/connect finished (pid 703), status = 0x0
Serial connection established.
using channel 4
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB2
Warning - secret file /etc/ppp/pap-secrets has world and/or group access
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x934f19f6> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x9 <asyncmap 0x0> <auth chap MD5> <magic 0xd10c05a6> <pcomp> <accomp>]
sent [LCP ConfNak id=0x9 <auth pap>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x934f19f6> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0xa <asyncmap 0x0> <auth pap> <magic 0xd10c05a6> <pcomp> <accomp>]
sent [LCP ConfAck id=0xa <asyncmap 0x0> <auth pap> <magic 0xd10c05a6> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x934f19f6]
Warning - secret file /etc/ppp/pap-secrets has world and/or group access
sent [PAP AuthReq id=0x1 user="cmnet" password=<hidden>]
rcvd [LCP DiscReq id=0xb magic=0xd10c05a6]
rcvd [LCP EchoRep id=0x0 magic=0xd10c05a6 93 4f 19 f6]
rcvd [PAP AuthAck id=0x1 ""]
PAP authentication succeeded
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [LCP EchoReq id=0x1 magic=0x934f19f6]
IPCP: timeout sending Config-Requests
sent [LCP TermReq id=0x2 "No network protocols running"]
sent [LCP TermReq id=0x3 "No network protocols running"]
Connection terminated.
Modem hangup

[1]+ Done(16) pppd call wcdma

================================================

Any Suggestions, thank you

Outcomes