AnsweredAssumed Answered

core-image-sato fails to build

Question asked by Neil Patel on Aug 30, 2019
Latest reply on Sep 23, 2019 by Neil Patel

When I try to build core-image-sato, or any x11 based image for a custom IMX6D based board in poky warrior, I get the following error:

 

repo: using cache for: oe-repo
not found other for:
not found modules for:
not found deltainfo for:
not found updateinfo for:
oe-repo: using metadata from Fri 30 Aug 2019 04:15:27 PM UTC.
Last metadata expiration check: 0:00:01 ago on Fri 30 Aug 2019 04:15:27 PM UTC.

No module defaults found
--> Starting dependency resolution
--> Finished dependency resolution
Error:
 Problem: package packagegroup-core-x11-base-1.0-r1.noarch requires packagegroup-core-x11-xserver, but none of the providers can be installed
  - conflicting requests
  - nothing provides xf86-video-imx-vivante needed by packagegroup-core-x11-xserver-1.0-r40.custom
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

 

I have the meta-freescale layer in my bblayers.conf file, and I can even build xf86-video-imx via "bitbake xf86-video-imx-vivante". Any suggestions on getting passed this issue? I've already tried doing a clean build, but with no luck.

 

Thanks,

Neil

Outcomes