AnsweredAssumed Answered

uART Interrupt Issue for T1042

Question asked by unknown issuee on Aug 30, 2019
Latest reply on Sep 13, 2019 by unknown issuee

I mentioned this problem in another question without giving my uART driver example and  I want to share my uART Interrupt Driver Application with you  maybe you can help to solve this problem. I spent a lot of time to solve this problem but I didnt solve in any manner. I run this application as standalone on T1042 board. I place uART driver to ram by u-boot tftp command and after that i run bootelf command of u-boot to execute uART Driver application. by the way, The content of IVPR register is 0x7ff10000

 

when I send serial data to the board  Interrupt handler doesnt run or CPU doesnt call interrupt handler function. It jumps another exception handler like below picture. uART Driver  is attached. you can look at it and say what i make mistakes in code side.

 

after i run application, I send serial data to the application over uART but i get this message like below.

 

error message

 

thanks in advance.

Attachments

Outcomes