AnsweredAssumed Answered

sdk_dpaa missing from mainline kernel?

Question asked by Francois Gervais on Aug 27, 2019
Latest reply on Sep 3, 2019 by Yiping Wang

It seems that freescale/sdk_dpaa is missing from the mainline kernel.

 

There seem to be a freescale/dpaa but that doesn't seem to work with the ethernet interfaces of the ls1043ardb board as it fails with:

 

[ 2.775370] fsl_dpaa_mac 1ae0000.ethernet: dpaa_fq_alloc() failed
[ 2.781463] fsl_dpaa_mac 1ae0000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.788524] fsl_dpa: probe of dpaa-ethernet.0 failed with error -12
[ 2.795077] fsl_dpaa_mac 1ae2000.ethernet: dpaa_fq_alloc() failed
[ 2.801168] fsl_dpaa_mac 1ae2000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.808214] fsl_dpa: probe of dpaa-ethernet.1 failed with error -12
[ 2.814754] fsl_dpaa_mac 1ae4000.ethernet: dpaa_fq_alloc() failed
[ 2.820844] fsl_dpaa_mac 1ae4000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.827882] fsl_dpa: probe of dpaa-ethernet.2 failed with error -12
[ 2.834421] fsl_dpaa_mac 1ae6000.ethernet: dpaa_fq_alloc() failed
[ 2.838293] ata1: SATA link down (SStatus 0 SControl 300)
[ 2.840515] fsl_dpaa_mac 1ae6000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.852942] fsl_dpa: probe of dpaa-ethernet.3 failed with error -12
[ 2.859481] fsl_dpaa_mac 1ae8000.ethernet: dpaa_fq_alloc() failed
[ 2.865574] fsl_dpaa_mac 1ae8000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.872609] fsl_dpa: probe of dpaa-ethernet.4 failed with error -12
[ 2.879149] fsl_dpaa_mac 1aea000.ethernet: dpaa_fq_alloc() failed
[ 2.885239] fsl_dpaa_mac 1aea000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.892288] fsl_dpa: probe of dpaa-ethernet.5 failed with error -12
[ 2.898826] fsl_dpaa_mac 1af0000.ethernet: dpaa_fq_alloc() failed
[ 2.904916] fsl_dpaa_mac 1af0000.ethernet: dpaa_alloc_all_fqs() failed
[ 2.911953] fsl_dpa: probe of dpaa-ethernet.6 failed with error -12

 

What would be the correct mainline driver to use?

Outcomes