AnsweredAssumed Answered

Not able to set Bootanimation for i.MX8m mini using Android 9

Question asked by Sahil Kulkarni on Aug 26, 2019
Latest reply on Sep 6, 2019 by Aldo Gutierrez

Hello,

I am having  i.MX 8M Mini EVK and have flashed Android 9 latest version 2.3.0 from NXP site https://www.nxp.com/design/development-boards/i.mx-evaluation-and-development-boards/android-os-for-i.mx-applications-processors:IMXANDROID?&tab=Design_Tools_Tab 

"android_p9.0.0_2.3.0_image_8mmevk.tar.gz" on SD card using UUU, i could use Android 9 on it, also i can download custom App using ADB from Android Studio using Windows and Linux.

 

 

My next task is to set Bootanimation with custom images and logo. Currently i can see Android boot animation which is the default one. Looking at many videos i copied the bootanimation.zip (  https://community.nxp.com/docs/DOC-330208 downloaded from NXP forum, to start with, as i can change that later to my own ) into /_/system/media/ and also to /data/local inserting SD card to linux PC.

 

It gave no change.

 

Later when i explored, i noticed that the location i copied the file, i could not see the bootanimation.zip when i use ADB shell command to get into device. Later using boot animation is not working i followed the steps there, i could push the zip file to SD card, but failed to mount the /system into write mode, https://community.nxp.com/thread/495380 , i also faced the same issue here, i could not execute  fastboot oem unlock, when i hit reboot bootloader the system reboots with blank screen and holds on terminal without any prompt, i need to press Ctrl + c to get myself into U boot , i tried to use fastboot commands, but i get error saying 

 

u-boot=> fastboot oem unlock
fastboot - use USB Fastboot protocol

Usage:
fastboot <USB_controller>
- run as a fastboot usb device
u-boot=> 

 

When i change command to fastboot sd or fastboot USB, then it removes uboot prompt and waits infinite, until i hit ctrl +c, 

 

Please guide me.

 

I am trying to explore on internet, but the solutions are not working for me.

 

I want boot animation to run, and for that i think placing it into /system/media shall do my work, but to do so i want write permission, i am not able to mount /system because  mount: '/system' not in /proc/mounts, to do so i think i need to boot myself into fastboot mode, i am not able to do so as fastboot is not able to execute itself ( or i am not able to get that done ). I also tried to change the setenv to androidboot.dm_verity=disable, still no luck.

 

On device when i hit whoami, i get root.

My i.MX8mm also has USB debugging On and also OEM setting On. 

 

Thanks in Advance !!!!!

-

Sahil Kulkarni

Outcomes