AnsweredAssumed Answered

K64 /Reset problem

Question asked by Geoff Gross on Aug 15, 2019
Latest reply on Aug 19, 2019 by Geoff Gross

Hi all -

 

I have a new PCB with a MK64FN1M0CAJ12R micro that we cannot program via JTAG.  

 

I believe I have traced the problem down to the /RESET line.  On this PCB, the reset pin onthe K64 connects to an external connector, a 100k pullup resistor, and an NFET that shorts reset to GND for about 400ms upon power up.  

Simplified schematic drawing below:

 

 

After power on, it appears that the reset pin is being pulled low inside the micro itself.  Every 50us or so it looks like the micro attempts to release the pin and allow it to be pulled high through the external pullup for about 1.5us, then it clamps back down and yanks it low again.  

 

See the attached plots. (blue is Vcc, yellow is /RESET)  Also note that these pictures are with the NFET removed, so as to get a better view of both the power supply rise and the reset behavior in the same picture - with the NFET installed, there is a ~400ms period where reset is shorted to ground through the FET.

 

I've tried a few things:

1. Changing the (external) pullup to 1k (no change)

2. Adding anywhere from 2200pF to 0.47uF of bypass capacitance on the /reset line, both to ground and Vcc. (It probably doesn't matter much whether it's ground or Vcc, but I tried both.)  This changes the character of the pulses; the RC has a clear effect, and makes it look like more of a charge/discharge RC oscillator, but the micro still does not seem to release reset.  This does seem to change the ~50usec interval that the micro appears to release on as well, looks more like ~250-300us with a 1k/0.47u combo on the /reset line.  

3. Forcing /reset low with tweezers (comes back up in the weird oscillating state when released, similar to after the FET releases upon power up)

4. Removed the NFET and connector entirely, just to be sure they weren't doing anything. (no change in behavior)

 

My coworker discovered the same issue on the k64 processor on another design.  However, this is the first time I've seen it myself, and this is the fourth iteration of this same reset circuit.  (previous three PCBs worked fine.)

 

So my questions are:

1. is this something that is known to happen with this micro, or have you seen it before due to some external cause I don't understand?

2. How can I address it?

 

Thanks,

Geoff Gross

geoff.gross@dtsweb.com

(562) 493-0158

Outcomes