AnsweredAssumed Answered

Unable to build Yocto for NXP

Question asked by Sayan Sinha on Aug 14, 2019
Latest reply on Sep 30, 2019 by Diego Adrian Cuevas

Hello everyone,

 

  I was trying to build Yocto for my NXP. I tried building the Meta Freescale layer (meta-freescale - Layer containing NXP hardware support metadata). As mentioned in the Yocto Project Quick Build page, I added the Meta Freescale layer to bitbake using `bitbake-layers add-layer ../meta-freescale-2.2`. Unfortunately, when I run `bitbake meta-freescale-2.2`, I get an error message 

   

```

ERROR: ParseError at ~/poky/meta/classes/image.bbclass:18: Could not inherit file classes/image_types_uboot.bbclass | ETA: 0:00:06

Summary: There were 3 WARNING messages shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

```

 

Any insights on this would be constructive. I would also like to mention that my final aim is to build Yocto (with RTOS support, preferably using Litmus RT) for NXP SBC-S32V234.

 

Thanks a lot in advance!

SBC-S32V234

Outcomes