AnsweredAssumed Answered

MCIMX6UL-EVK can't boot

Question asked by Jason Shao on Aug 12, 2019
Latest reply on Aug 12, 2019 by igorpadykov

Hello,

I am trying to boot my MCIMX6UL-EVK board with below 3 ways, but all failed. Who can help me? 

① Made a SD card to boot:

      I download the image files from  L4.14.98_2.0.0_MX6UL7D and write the fsl-image-validation-imx-imx6ul7d.sdcard to my 4GB SD card with this command " sudo dd if=fsl-image-validation-imx-imx6ul7d.sdcard of=/dev/sdx bs=1M && sync". Then plug the SD card into the main bord and set the DIP switchs to SD card boot. But when I power up, it didn't boot, there are no any logs from J1901. I also tried different images from  L4.1.15_1.1.0_iMX6UL and  L4.1.15_2.0.1_iMX6UL7D but all failed. I dont know what to do now.

② Try to download image with MfgTool:

      I tried to download the images to SD card through MfgTool by running mfgtool2-yocto-mx-evk-sdcard-sd2.vbs. But it hang on "Jumping to OS Image".

③ Try to do ddr stress test

      I tried to do ddr stress test with ddr_stress_tester_v2.70. But got an Error like this:

ddr_mr1=0x00000000

Start write leveling calibration...

running Write level HW calibration

Write leveling calibration completed, update the following registers in your initialization script

MMDC_MPWLDECTRL0 ch0 (0x021b080c) = 0x001F0000

Write DQS delay result:

Write DQS0 delay: 0/256 CK

Write DQS1 delay: 31/256 CK

 

Starting DQS gating calibration

. HC_DEL=0x00000000 result[00]=0x00000011

. HC_DEL=0x00000001 result[01]=0x00000011

. HC_DEL=0x00000002 result[02]=0x00000011

. HC_DEL=0x00000003 result[03]=0x00000011

. HC_DEL=0x00000004 result[04]=0x00000011

. HC_DEL=0x00000005 result[05]=0x00000011

. HC_DEL=0x00000006 result[06]=0x00000011

. HC_DEL=0x00000007 result[07]=0x00000011

. HC_DEL=0x00000008 result[08]=0x00000011

. HC_DEL=0x00000009 result[09]=0x00000011

. HC_DEL=0x0000000A result[0A]=0x00000011

. HC_DEL=0x0000000B result[0B]=0x00000011

. HC_DEL=0x0000000C result[0C]=0x00000011

. HC_DEL=0x0000000D result[0D]=0x00000011

ERROR FOUND, we can't get suitable value !!!!

dram test fails for all values.

 

Error: failed during ddr calibration

 

Now I suspect there is something wrong with DDR, and dont know what to do. Please help me!

Thanks!

Outcomes