AnsweredAssumed Answered

Unsupported version of the LPSCI Driver in the toolchain/IDE project. Required: 2.0.4, actual: 2.0.3.

Question asked by 亢亢 陈 on Aug 8, 2019
Latest reply on Aug 19, 2019 by Jing Pan

Hi,

I downloaded the last verrsion of SDK.2.2.0

But I use MCUXpresso Config Tools v6 to configure UART0 and UART2,it says :

 

Level: Warning
Type: Validation
Tool: Toolchain/IDE project
Issue: Unsupported version of the LPSCI Driver in the toolchain/IDE project. Required: 2.0.4, actual: 2.0.3.
Origin: Peripherals
Target: Toolchain/IDE project: core0
Resource: platform.drivers.lpsci

 

Level: Warning
Type: Validation
Tool: Toolchain/IDE project
Issue: Unsupported version of the UART Driver in the toolchain/IDE project. Required: 2.1.5, actual: 2.1.4.
Origin: Peripherals
Target: Toolchain/IDE project: core0
Resource: platform.drivers.uart

 

 I run the code anyway.  if it runs    base->D = *(data++);   it will be a hard fault

I don't know how to slove this problem.Can you help me?

Outcomes