AnsweredAssumed Answered

Missing spidev on Solidrun Hummingboard Pulse (iMX8)

Question asked by Gary G on Aug 7, 2019
Latest reply on Aug 7, 2019 by jamesbone

When flashing the sdcard using the official provided Debian image Index of /IMX8/Debian/ on the Solidrun Hummingboard Pulse, I can't find any /dev/spidev*.

 

Following is the fsl-imx8mq.dtsi device tree file and I noticed the status is set to 'disabled'? I think a spidev node should be added here?

 

    ecspi1: ecspi@30820000 {
        compatible = "fsl,imx6ul-ecspi", "fsl,imx51-ecspi";
        reg = <0x0 0x30820000 0x0 0x10000>;
        interrupts = <GIC_SPI 31 IRQ_TYPE_LEVEL_HIGH>;
        clocks = <&clk IMX8MQ_CLK_ECSPI1_ROOT>,
             <&clk IMX8MQ_CLK_ECSPI1_ROOT>;
        clock-names = "ipg", "per";
        interrupt-parent = <&gpc>;
        status = "disabled";
    };

Outcomes