AnsweredAssumed Answered

ISC dhcpd is ignoring BOOTP requests in Sumo BSP

Question asked by James Puckett on Aug 5, 2019
Latest reply on Aug 20, 2019 by Diego Adrian Cuevas

Our setup:

  • Our i.MX6 based board running Linux built using the sumo BSP
    • Linux kernel 4.14.78
    • This is building dhcpd 4.3.6
  • We're booting via NFS from a VM.  u-boot passes the kernel a static IP of 10.43.30.3
  • All devices are on a separate Ethernet switch:
    • Laptop (running the VM)
    • i.MX6s board
    • Ethernet camera

 

Details:

Our customer has provided us with Ethernet cameras that expect to have their IP addresses assigned via DHCP.  I had this working with a previous version of the BSP but we had to switch to sumo for various reasons.  Using the same dhcpd.conf file that worked previously, dhcpd now ignores all BOOTP requests.  Running tcpdump shows that the messages are making it to our board.

 

For kicks I tried running udhcpd with the default configuration and it immediately assigned the camera an IP address.  This leads me to believe that there is some new dhcpd setting that I'm missing somewhere.  We can't use udhcpd because our customer requires that we only assign IPs to certain MAC addresses and I don't see that udhcpd has that ability.

 

I have also plugged in a Windows laptop with DHCP enabled to see if there's something wrong with the way the cameras are sending their requests.  Again I could see the messages making it to the board using tcpdump but dhcpd ignored them.

 

I have attached the dhcpd.conf, network/interfaces and default/dhcp-server config files we have been using.

Attachments

Outcomes