AnsweredAssumed Answered

DESFire change key APIs issues on library v05.22.01

Question asked by david huang on Jul 31, 2019
Latest reply on Aug 14, 2019 by david huang

Dear support team,

 

We use CLRC663 and try to port the library (NXP NFC Reader Library v05.22.01) into our STM32 MCU.

We found some issues that the new library lacks some APIs that the old version library has, and this makes us cannot correctly access DESFire EV1/EV2 card data.

Following lists the issues that we met:

  1. The APIs in phalMfdf of the new library (V05.22.01) are same to the old version, does that mean NXP now not to support or provide the DESFire Library?
  2. If we can use the phalMfdfLight (V05.22.01) to access DESFire Light card, are these APIs be able to use to access non-EV2 DESFire card as well?
  3. The phalMfdfLight has more APIs than phalMfdf (for V05.22.01 library), but it still lacks such as ChangeKeySettings、DeleteApplication APIs, this makes us not be able to modify or delete the Application key settings. Is there any way to get the key management APIs?

 

Thanks~

 

Best Regards,
David Huang##

Outcomes