AnsweredAssumed Answered

MCUXpresso often won't do PRINTF to Console in 'hello world' example

Question asked by Jon Green on Jul 30, 2019
Latest reply on Aug 12, 2019 by Jon Green

Hi, I found that sometimes I don't get any PRINTF output in debugger Console window. So I reverted to the 'hello world' example and found that also has the problem.

I'm running the 'hello world example from SDK-_2-2, MCUXpresso 11.0.0_2516 for LPC55S69 on Mac OS-X.

 

When PRINTF works, I see message in Console window (if I recall correctly) about telnet successful, and no such message when PRINTF issn't working.

 

At one point I wondered if I'd run out of memory/resources so I closed all my other apps and browser windows and then it did seem to work, but that may have been a fluke because that never made it work when it next stopped working.

 

Is there some log file somewhere that would give info about anything that went wrong? 

 

Screenshot attached where I've stepped past the PRINTF line with no console output.

Screenshot where I've stepped past PRINTF line an got no console output.

I've pasted info from IDE support info below...

Binaries path: /Applications/MCUXpressoIDE_11.0.0_2516/ide/plugins/com.nxp.mcuxpresso.tools.bin.macosx_11.0.0.201905221151/binaries/

Tools path: /Applications/MCUXpressoIDE_11.0.0_2516/ide/plugins/com.nxp.mcuxpresso.tools.macosx_11.0.0.201905131304/tools/

Wizards path: /Applications/MCUXpressoIDE_11.0.0_2516/ide/plugins/com.nxp.mcuxpresso.tools.wizards_11.0.0.201902141834/Wizards/

Product: MCUXpresso IDE
Version: MCUXpresso IDE v11.0.0 [Build 2516] [2019-06-05]
Operating system: Mac OS X
VM: Java HotSpot(TM) 64-Bit Server VM (64 bit)

Outcomes