AnsweredAssumed Answered

Cannot read memory on T2080QDS from CodeWarrior

Question asked by Ka Kay Achacoso on Jul 30, 2019
Latest reply on Aug 4, 2019 by Pavel Chubakov

I have a T2080QDS board with CodeWarrior USB Tap (the older version without network connection).  

When I start the debug configuration for my project, I am unable to view the memory in RAM at 0x00000000.  The Memory view gives the following error message:

 

Target request failed:  CCSProtocolPlugin:  Error reading emory

[CCS last error: Scan timeout ].

 

I'm able to view the NOR flash at 0xe8000000, but only up until 0xe8000100 or so.  If I read anything beyond that, I get the same error message.  I'm also unable to read 0xeff80000, which gives me the same error message.  So I can't read Bank 0 and the address where u-boot is supposed to start.

 

Ultimately, I'm trying to flash the NOR flash with u-boot by following the instructions in AN4948 Flash Programmer for CodeWarrior Power Architecture to flash the NOR flash.  I'm using the T2080QDS_NOR_FLASH.xml file provided with CodeWarrior Power Architecture.  I get this error:

 

Error:  Connect Failed.  CCSProtocolPlugin::Could not connect to the requested core #0.

 

I'm guessing this error is caused by Code Warrior not being able to read the RAM or the NOR flash.  

What is my problem?

Thanks.

Outcomes