AnsweredAssumed Answered

Serial Port Connection Failure FRDM K66f

Question asked by Isabel Hegedus on Jul 18, 2019
Latest reply on Jul 29, 2019 by Felipe García

I have a K66f board and am attempting to run the Virtual COM cdc Bluetooth example included in the board SDK. However, after launching the appropriate COM port in PuTTY and running the debug function in MCUxpresso, I am receiving an error saying that PuTTY is unable to "read from the serial device" as shown below. I have checked my cables. I tried to run this program with both the power/debug and usb/terminal output plugged into the same windows 10 machine. Thinking that may be the problem, I tried running the debugging/power supply from one windows 10 machine and plugged the secondary usb transmitting the  terminal output in another  windows 10 machine. I receive the same error in all circumstances. Iv'e seen suggestions for re downloading the OpenSDA package, but I know there are problems with corruption in BOOTLOADER mode on windows 10 machines, so I am hesitant to do that. Is re-instillation of the firmware the only practical next step, or are there other options that I could try. Any guidance would be helpful!

Attachments

Outcomes