AnsweredAssumed Answered

IMX1050RT Stuck at ResetISR

Question asked by BENJAMIN OLAYINKA on Jul 12, 2019
Latest reply on Jul 21, 2019 by jeremyzhou

My project is stuck at ResetISR() in startup_mimx1052.c. It randomly started doing this when I added a breakpoint and then restarted the debugger. If I try to step in to the function, it just resets and stays at the same line. I think it's related to the REDLIB __main function because if I rename my main to __main, then the debugger reaches my program code but I have no semihosting console.

 

Things I've tried

Switching between semihosting and no hosting REDLIB, this worked temporarily but it's now stuck again.

Investigating REDLIB __main, I can't find the function anywhere in the project. Looking at other projects, I see it in the project.map file, but I guess it's a precompiled binary or something? Why can't I find it in the project?

Switching to NEWLIB, this should bypasses the call to __main but I still end up stuck at ResetISR.

 

Help! These cryptic errors make developing on this board a pain ;(

Outcomes