AnsweredAssumed Answered

IMX6Q-SABREAUTO EVK board boot failed using Android 9

Question asked by May Queen on Jul 5, 2019
Latest reply on Jul 8, 2019 by Wigros Sun

Platform: IMX6Q

OS: Android 9 (p9.0.0-2.2.0-ga)

 

As title, I tried the android 9 on IMX6Q-SABREAUTO EVK board but boot failed, it looks good before running into system, but it shows services failed when start running  zygote..

 

log:

type=1400 audit(1562322318.470:10255): avc: denied { dac_read_search } for pid=1072 comm="main" capability=2 scontext=u:r:zygote:s0 tcontext=u:r:zygote:s0 tclass=capability permissive=0
type=1400 audit(1562322319.730:10256): avc: denied { dac_read_search } for pid=241 comm="Binder:241_4" capability=2 scontext=u:r:installd:s0 tcontext=u:r:installd:s0 tclass=capability permissive=0
init: Received control message 'interface_start' for 'android.hardware.sensors@1.0::ISensors/default' from pid: 190 (/system/bin/hwservicemanager)
init: Could not find service hosting interface android.hardware.sensors@1.0::ISensors/default
init: Received control message 'interface_start' for 'android.hardware.sensors@1.0::ISensors/default' from pid: 190 (/system/bin/hwservicemanager)
init: Could not find service hosting interface android.hardware.sensors@1.0::ISensors/default
healthd: battery l=85 v=3 t=35.0 h=2 st=2 c=400 fc=4000000 cc=32 chg=a
healthd: battery l=85 v=3 t=35.0 h=2 st=2 c=400 fc=4000000 cc=32 chg=a

Seems the sensors service has some problem, but it also shows the same messages when I take out the sensors configuration from device/fsl/imx6dq/sabreauto_6q/sabreauto_6q.mk

Any directions? I stocking almost one week... thanks

Outcomes