AnsweredAssumed Answered

SDK_2.6.0_MIMX8MM6xxxLZ not compatible with MCUXpresso IDE?

Question asked by Steven Marks on Jul 4, 2019
Latest reply on Jul 5, 2019 by Steven Marks

When I check add the SDK_2.6.0_MIMX8MM6xxxLZ to MCUXpresso IDE I get the error below. It seems that the SDK is not compatible with IDE. I also checked IDE supported list and it doesn't seem to support M4 coprocessors yet.

 

I was just wondering when this support will be available for the IDE?

 

eclipse.buildId=unknown
java.version=1.8.0_201
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_CA
Command-line arguments: -data file:/home/steven/Work/IMX8MM-M4/workspace/ -os linux -ws gtk -arch x86_64

com.nxp.mcuxpresso.core.datamodels
Error
Thu Jul 04 13:47:14 PDT 2019
The SDK 'SDK_2.x_MIMX8MM6xxxLZ' does not contain any MCUXpresso IDE compatible toolchain.


at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:810)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:797)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$2.preVisitDirectory(SDKManifestProvider.java:588)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$2.preVisitDirectory(SDKManifestProvider.java:1)
at java.nio.file.Files.walkFileTree(Files.java:2677)
at java.nio.file.Files.walkFileTree(Files.java:2742)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:580)
at com.nxp.mcuxpresso.core.datamodels.SDKChipVendorDatabase.refresh(SDKChipVendorDatabase.java:797)
at com.nxp.mcuxpresso.core.datamodels.ui.views.SDKView.doDBRefresh(SDKView.java:1308)
at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:112)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

Outcomes