AnsweredAssumed Answered

LS1021A TBI Phy Address configure

Question asked by zhq li on Jul 4, 2019
Latest reply on Jul 17, 2019 by zhq li

I have succeed in modifing TBI phy address by modifing TBIPA and MIIMADD registers. Also I tried this in device tree. But it does not work. The following is my modifications with device tree. 

 

tbi-phy@1f {
reg = <0x1f>;
device_type = "tbi-phy";
linux,phandle = <0xa>;
phandle = <0xa>;
};

 

tbi-phy@1e {
reg = <0x1e>;
device_type = "tbi-phy";
linux,phandle = <0x12>;
phandle = <0x12>;
};

...

ethernet@2d50000 {
compatible = "fsl,etsec2";
device_type = "network";
#address-cells = <0x2>;
#size-cells = <0x2>;
interrupt-parent = <0x1>;
model = "eTSEC";
ranges;
dma-coherent;
/*tbi-handle = <0xa>;*/
tbi-handle = <0x12>;
phy-connection-type = "sgmii";
status = "okay";

 

I add a tbi-phy node with address 0x1e. When I boot up my board. It gives some error "net eth1: error: Could not get TBI device". I try to modify TBI phy address in phandle 0xa, and I get the same result. It seems that in device tree the TBI phy must be 0x1f. Could you give me a favor? Thanks.

 

Outcomes