AnsweredAssumed Answered

MCUXpresso IDE Config Tools Peripherals -- how to fix "unsupported version of the Driver in the toolchain/IDE project"?

Question asked by Nick Sunshine on Jun 29, 2019
Latest reply on Jul 8, 2019 by Nick Sunshine

Hello all,

 

I'm very new to using MCUXpresso IDE & Config Tools so my apologies in advance if this is a novice question.  I'm trying to explore adding a peripheral support to a FRDM-KW36 project using MCUXpresso IDE Config Tools Peripherals GUI.  I'm trying to start with something simple (seemingly) like an interrupt handler for a GPIO.  When I go to the Peripherals view and Components pane and click on the plus icon next to the "Peripheral drivers" label I get the following error on the tooltip:

 

 

Furthermore, if I ignore it and just click OK, I get a "Problem Occurred" window popup saying " 'UI refresh' has encountered a problem.  An internal error has occurred."  Expected I guess as it warned me about the incompatibility.

 

My question is, how do I update the driver versions?  It says I need 2.2.1 and I have 2.2.0 for GPIO.  My understanding is that this is tied to my SDK.  I recently downloaded the standard FRDM-KW36 SDK from NXP's website, so I don't understand why it would be incompatible.  In any case, what is the best way to go about updating the drivers where I'm getting those warning icons?

 

Thank you in advance for your assistance.

 

Regards,

 

Nick 

Outcomes