AnsweredAssumed Answered

Why is i.MX53 BulkIO device changing to USB Mass Storage device when I run MFG tool?

Question asked by Brian Peters on Jun 19, 2019
Latest reply on Jun 25, 2019 by Brian Peters

Running  MFG tool  rev 1.6.032  on a windows 10 upgrade of a windows 7 PC with no usb3 ports, every thing is configured correctly best I can tell.  The target board shows up as a  'Freescale i.MX53 USB BulkIO device'  in the USB tree in device manager, when connected and powered up. When run the  MFG tool recognizes the board and when I click on start  it begins to program  the selected profile.  A few steps into the Programming MFG tool appears to freeze and the  'Freescale i.MX53 USB BulkIO device' disappears from  the Device manager tree and is replace by an entry for a 'USB Mass Storage Device'.  I have confirmed that this is what is happening by turning the target device off at which point the  'USB Mass Storage Device' is removed from the Device manager tree.  When I turn the target back on it appears as a  'Freescale i.MX53 USB BulkIO device'.   The MFGTool eventually times out and generates an error.

atached are screen caps for :

error in MFGTool  (032 ver error)

Device manager USB tree before (DM usb1) and after the problem occurs  (DM usb2)

 

Also attached is a copy of the MFG tool log file when this occurs. (mfgtool032.log)

 

This problem also occurs with  a Beta version of the MFGTool   rev 1.6.2.055  provided to me by Igor Padykov 

In response to a previous solved problem with USB3 ports  https://community.nxp.com/thread/504754.

This version is working correctly on  both a Windows 10 and Windows 7 machine with USB3.0 ports.

Screen cap (MFG fault)

Log file  (mfgtool 1.log)

 

 

Can anybody help with this new problem?

 

Regards,

Brian

 

 

 

Outcomes