Michael Lindell

Unlock kinetis on SKEAZN32XXX2

Discussion created by Michael Lindell on Jun 13, 2019
Latest reply on Jun 14, 2019 by Michael Lindell

Greetings,


I am currently working with SKEAZN32XXX2 on a custom board. The SKEAZN32XXX2 is programmed through connecting a SEGGER J-Link Arm programmer and then reading a binary file to it (usually through SEGGER J-Flash Lite V6.44a).

 

I have been able to both program it and erase without any problems until recently. 

The problem first occurred when I pressed "Erase Chip" in J-Flash Lite followed by pressing it "Erase Chip" again.

If I use Jlink Commander I am able to connect to the processor (through SWD) and I am able to read out the whole data flash from the processor (which only consists of 0xFF at the moment). 

 

Furthermore, I have tried to use the command Unlock Kinetis (since the MCU is of that family). The response to that is "Unlocking device..Timeout while unlocking device."

Then I have tried to program the device again with the result of "Communication timed out: Requested 4 bytes, received 0 bytes!

Target voltage too low (1 Volt is required, Measured: 0.0 Volt).

Unspecified error -1".See attached screenshot for exact output.

 

I have read some related posts on the issue (for different MCUs):

https://community.nxp.com/thread/300407

https://community.nxp.com/thread/447276

and some from the J-Link forum:

https://forum.segger.com/index.php/Thread/1074-Error-Supply-voltage-too-low-with-J-Link-and-BeagleBoard/

https://forum.segger.com/index.php/Thread/2390-JLink-on-unsecure-and-erase-Kinetis-FLASH/?postID=8024&page=Thread#post8024

 

With that being said, my two main questions are why exactly does this problem occur and is there a way to unlock/recover the SKEAZN32XXX2 chip again from this mode?

 

Best regards,

Michael.

Attachments

Outcomes