AnsweredAssumed Answered

Imx8 multilib Yocto build fails

Question asked by Gábor Jákli on Jun 12, 2019
Latest reply on Jul 10, 2019 by Jonathan Guttmann

Dear all

 

I'm pretty new to build yocto project. Therefore I carefully followed the instructions in the i.MX Yocto Project User's Guide (Rev. L4.14.98-2.0.0_ga, 04/2019) about setting up the environment and use the correct Distro and machine config for imx8m quad eval kit.

I managed to complie the 'fsl-image-qt5-validation-imx' image using DISTRO="fsl-imx-wayland" MACHINE="imx8mqevk".

 

However I realized that I need 32bit libs aswell since not all my applications can be compiled to 64bit environment. So I followed the instructions to configure the multilib environment.

But unfornutely I ran into a problem

 

ERROR: rapidjson-1.1.0+gitAUTOINC+e5635fb27f-r0 do_package: QA Issue: rapidjson: Files/directories were installed but not shipped in any package:
/usr/lib
/usr/lib/cmake
/usr/lib/pkgconfig
/usr/lib/cmake/RapidJSON
/usr/lib/cmake/RapidJSON/RapidJSONConfig.cmake
/usr/lib/cmake/RapidJSON/RapidJSONConfigVersion.cmake
/usr/lib/pkgconfig/RapidJSON.pc
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
rapidjson: 7 installed and not shipped files. [installed-vs-shipped]
ERROR: rapidjson-1.1.0+gitAUTOINC+e5635fb27f-r0 do_package: Fatal QA errors found, failing task.
ERROR: rapidjson-1.1.0+gitAUTOINC+e5635fb27f-r0 do_package: Function failed: do_package
ERROR: Logfile of failure stored in: /home/nng/imx-yocto-bsp/build-wayland/tmp/work/aarch64-poky-linux/rapidjson/1.1.0+gitAUTOINC+e5635fb27f-r0/temp/log.do_package.17579
ERROR: Task (/home/nng/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb:do_package) failed with exit code '1'
ERROR: devil-1.8.0-r0 do_package: QA Issue: devil: Files/directories were installed but not shipped in any package:
/usr/lib/libIL.so
/usr/lib/libILUT.so
/usr/lib/libILU.so
/usr/lib/pkgconfig
/usr/lib/pkgconfig/ILUT.pc
/usr/lib/pkgconfig/ILU.pc
/usr/lib/pkgconfig/IL.pc
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
devil: 7 installed and not shipped files. [installed-vs-shipped]
ERROR: devil-1.8.0-r0 do_package: Fatal QA errors found, failing task.
ERROR: devil-1.8.0-r0 do_package: Function failed: do_package
ERROR: Logfile of failure stored in: /home/nng/imx-yocto-bsp/build-wayland/tmp/work/imx8mqevk-poky-linux/devil/1.8.0-r0/temp/log.do_package.17582
ERROR: Task (/home/nng/imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-graphics/devil/devil_1.8.0.bb:do_package) failed with exit code '1'

 

So two packages are failing in do_package phase

 

/home/nng/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-devtools/rapidjson/rapidjson_git.bb:do_package
/home/nng/imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-graphics/devil/devil_1.8.0.bb:do_package

And the imx-gpu-sdk-5.3.0 fails at do_compile phase because the libIL is unavailable. It's should be in the devil_1.8.0 package but it failed previously. I manually checked in the 'tmp' dir, libIL.so exists but might not be copied into the correct folder.

/ld: cannot find -lIL

 

/home/nng/imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-graphics/imx-gpu-sdk/imx-gpu-sdk_5.3.0.bb:do_compile

I'm trying to figure out what should be added to the .bb files but no success so far. 


Does anyone have any suggestion?

 

Thank you in advance

Outcomes