Aaron Lager

PHY TX pulse is a runt, can't get link using mcf52233caf60

Discussion created by Aaron Lager on Feb 9, 2009
Latest reply on Feb 10, 2009 by Aaron Lager
print_004.png shows the pulse on the TXp and TXn pins.
print_005.png shows the pulse on the RXp and RXn pins.

What sort of things could cause this?  It has the right shape and timing, but the chip is not driving the signal high enough.  I compared the signals to the mcf52235eval board and both the rx and tx signals look like print_005.png.  I'm using the same S19 file to program both the eval board and my board, and it works fine on the eval board, but my board produces a runt pulse.
I've tried two different boards, two different chips, two different sets of magetics (pulse H2019 and magjack)
I've tried reversing TXp and TXn, all with the same exact results.

Any guidance would be great.  Also if anyone knows of a good FAE in the northbay (CA), let me know, ours just got laid off.

Thanks,
Aaron


Message Edited by alager on 2009-02-09 08:03 PM

Outcomes