AnsweredAssumed Answered

I cannot debug with P&E multilink Universal FX into the iMXRT1020-EVK

Question asked by Gustavo Parlanti on Jun 10, 2019
Latest reply on Jun 13, 2019 by Victor Jimenez

I cannot debug with P&E multilink Universal FX into the iMXRT1020-EVK

I can debug with the openSDA implemented into the board but when I want to debug with the Multilink FX the message that I obtain is the following:

P&E GDB Server for Arm(R) devices, Version 7.14.00.00
Copyright 2018, P&E Microcomputer Systems Inc, All rights reserved
Loading library C:\NXP\MCUXpressoIDE_10.3.1_2233_new\ide\plugins\com.pemicro.debug.gdbjtag.pne_3.9.9.201902081724\win32\gdi\unit_ngs_arm_internal.dll ... Done.
Command line arguments: -startserver -device=NXP_iMX_IMXRT1021
Device selected is NXP_iMX_IMXRT1021
HW Auto-Selected : Interface=USBMULTILINK Port=PEME39D39   ; USB1 : Multilink Universal FX Rev C (PEME39D39)
Connecting to target.
P&E Interface detected - Flash Version 10.18
Can not enter background mode.
Unable to initialize PEDebug.
PEmicro GDB Launch Failure : The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.
Target Disconnected.
I review all post and I try all things into the post and I cannot make it work. 
I open the jumper J27 and J28 to disconnect the openSDA. 
I don't know what else to do. 
I did a custom board and I have the same problem. 

Outcomes