AnsweredAssumed Answered

K64 custom board and MMA8451 I2C problems

Question asked by Bogdan Nica on Jun 3, 2019
Latest reply on Jun 5, 2019 by Kerry Zhou

Hello, i am working on a custom board using k64 and i have just accesed it via jtag,tested some basic pin I/O and it's ok.

I now have a problem accessing the MMA8451Q over I2C .

I have used the electrical schematic as advised in it's datasheet (SA0 is pulled down via 10k resistor). On the microcontroller side i am using PTE0 (I2C1_SDA) and PTE1(I2C1_SCL) both with 2k2 pull up resistors.

I have tried using the example from the sdk :  cmsis_i2c_read_accel_value_transfer .

I  have replaced the pins and port used in the example with my own and the console says that it is not able to find and accelerometer device.

I have also tried to modify the macro on line 22 into pointing to Driver_I2C1 instead of Driver_I2C0 and in the rest of the file into I2C1 but it gives compilation errors.

Any thoughts ?

Kerry Zhou would you be so kind as to lend me a helping hand once more ?

Outcomes