Karel Chaloupka

Problems with booting 547x development board using NFS.

Discussion created by Karel Chaloupka on Feb 6, 2009
Latest reply on Feb 9, 2009 by Karel Chaloupka
I'm having issues with booting using NFS. After setting up eth0 it looks like it can't find the NFS mount anymore. I've looked at my ip config and boot args values in u-boot and they look fine. Any suggestions?


Here are my u-boot environment vars
++++++++++++++++++++++++++++++++++++++++++++
U-Boot 1.3.3 (Aug  8 2008 - 16:51:13)

CPU:   Freescale MCF5484
       CPU CLK 200 Mhz BUS CLK 100 Mhz
Board: Freescale FireEngine 5485 EVB
I2C:   ready
DRAM:  64 MB
FLASH:  4 MB
In:    serial
Out:   serial
Err:   serial
Net:   FEC0, FEC1

-> print
bootdelay=1
baudrate=115200
ethaddr=00:e0:0c:bc:e5:60
eth1addr=00:e0:0c:bc:e5:61
hostname=M548xEVB
netdev=eth0
u-boot=u-boot.bin
load=tftp ${loadaddr) ${u-boot}
upd=run load; run prog
prog=prot off bank 1;era ff800000 ff82ffff;cp.b ${loadaddr} ff800000 ${filesize};save
ethact=FEC0
filename=uImage
loadaddr=02000000
partitions=mtdparts=physmap-flash.0:4M(kernel)ro,12M(root)
bootargs=root=/dev/nfs rw nfsroot=10.210.65.155:/tftpboot/ltib/rootfs ip=10.210.64.41:10.210.65.155:10.210.64.1:255.255.254.0::eth0:smileysurprised:ff
filesize=29DF8
fileaddr=2000000
gatewayip=10.210.64.1
netmask=255.255.254.0
ipaddr=10.210.64.41
serverip=10.210.65.155
stdin=serial
stdout=serial
stderr=serial
mem=65024k

+++++++++++++++++++++++++++++++++++++++++++++

Here is a snippet of the kernel boot output:

RPC: Registered udp transport module.
RPC: Registered tcp transport module.
IP-Config: Complete:
     device=eth0, addr=10.210.64.41, mask=255.255.254.0, gw=10.210.64.1,
     host=10.210.64.41, domain=, nis-domain=(none),
     bootserver=10.210.65.155, rootserver=10.210.65.155, rootpath=
Looking up port of RPC 100003/2 on 10.210.65.155
Looking up port of RPC 100005/1 on 10.210.65.155
VFS: Mounted root (nfs filesystem).
Setting the hostname to freescale
Mounting filesystems
Starting syslogd and klogd
Running sysctl
Setting up networking on loopback device:
Setting up networking on eth0:
nfs: server 10.210.65.155 not responding, still trying


+++++++++++++++++++++++++++++++++++++++++++++

Outcomes