AnsweredAssumed Answered

Problems with importing NXP examples into Codewarrior V11.1

Question asked by Mehrdad Ostovary on May 21, 2019
Latest reply on Jun 4, 2019 by Martin Kovar

Hi,

I loaded the examples for Gen4xs switches (Gen4eXtremeSwitch_PEx_SW.zip) and wanted to add the examples to Codewarrior workspace. I created a new project with existing code, select the directory and let copy the file to workspace.

The result is absolutley unuseable. At first sight it looks everything normal but when I try to compile it, then I get the message that there is nothing to do or there is no makefile.

After long search and try, I found that the setteings of the project are damaged. When I look at properties of the project, in C/C++ Build, Settings, Tool settings tab, I have no entries. I get an empty square with no content.

I got also code from NXP engineers which I tried to import with the same result.

I could import twice the project when I created a new empty project then close the project, delete the files and replace them with the wanted content and reopen the project but this is not working always and its not a real workaround. the goal ist to import them without such problems.

 

I need you help to solve this problem.

Thanks.

Outcomes