Bogdan Nica

MK66F custom board + LPC LINK2 JTAG problems

Discussion created by Bogdan Nica on May 16, 2019
Latest reply on May 30, 2019 by Kerry Zhou

Hello,

   I am working on a project that needed a custom board  using the kinetis mk66 microcontroller.

I have no space for a sda chip on the board so i am using the LPC LINK2 (J7) as the debugger using MCUXpresso IDE.

I have designed the jtag using the recommendations as per section 65.2 External signal description(page 2225/2247) and 10.3 Debug Port Pin Descriptions ( page 179/2247) with no external resistors attached.

 

The debugger soft loaded its firmware(CMSIS-DAP) and is seen by the MCUXpresso IDE.

I am powering my custom board from an external power supply so JP2 si off.

 

As this is my first design i have unfortunately not used the Reset_b pin and it is floating.

The first time i tried to flash the mk66,using the gui flash tool, i unknowingly performed a MASS ERASE and it looks like the reset mcu box is also ticked. Se i did a MASS ERASE + RESET and i have read it might be bricked ?

I will post pictures of the error i recieve .

Also, the unlock from the GUI Flash Tool does not work.

 

I have also measured the voltage between the pins and gnd to verify that the signals are pulled high/low as per the 65.2 External signal description. I have tried pulling the JTAG_TRST_b pin high by 10k resistor. I tried pulling TDO(because it has no internal pull) low and high and nothing happened.

I have imported the mk66f sdk and imported a project in the workspace.

I have also tried changing the launch configuration from SWD to JTAG in Debug Connection and changing the Vector catch and still nothing.

 

I keep getting the same error: Wire ACK fault in DAP access.

 

Is there anything i might do at this point ? Could i load the j-link firmware in the LPC Link2 and use the j-link debugger command window to issue some unlock or something ?

I will post screen shots .

Outcomes