Paul Swanson

Is my FRDM-KL25Z bricked? Please Help.

Discussion created by Paul Swanson on May 15, 2019
Latest reply on May 16, 2019 by Mark Butcher

Hi,

 

I've got a brand new FRDM-KL25Z which I've been trying to use with MCUXpresso, but I discovered it shipped with the old PEMicro firmware that doesn't work in 2019 (ie. only Win XP/7).

 

So, I downloaded the firmware update from PEMicro, read the PDF update instructions (which are wrong) and followed them. The computer I was using at the time was a Windows 10 PC. After copying the boot loader file and restarting the board I noticed the following:

 

 * No lights / activity when connected to either the OpenSDA or USB ports

 * In bootloader mode (ie. hold reset button) the D4 LED flashes 8 times rapidly every 

 * Tried to restore via Windows XP / 7 VM but bootloader update simply won't copy

 * Tried under Linux and bootloader update file copies

 * Now: no lights, no connectivity, no reset / bootloader mode

 

How can I get my board working?

 

And, is it normal for boards to come from NXP with ancient firmware that requires a ten year old computer to operate or it'll brick? Not to mention the ONLY accurate documentation for all this is some guy's blog. Sorry to say, but this is a terrible first experience for me, not happy at all, I just want to write some code ... not build a Win 7 PC. </rant end>

 

Please, please help.

 

Paul Swanson

 

PS. Yes, I've read: https://mcuoneclipse.com/2014/11/01/illustrated-step-by-step-instructions-updating-the-freescale-freedom-board-firmware/ AFTER it became clear that ALL supplied documentation from NXP & PEMicro was just plain wrong.

Outcomes