AnsweredAssumed Answered

ls1046a rdb run dpdk l3fwd problem

Question asked by Yi-Lin Hsieh on May 13, 2019
Latest reply on Jun 2, 2019 by Yi-Lin Hsieh

Hi all, 

 

I try to run lsdk 18.12 dpdk  l3fwd example on ls1046ardb.

I followed 9.2.4.4 DPDK example applications in LSDK-KC-REV18.12.

l3fwd -c 0x6 -n 1 -- -p 0x3 --config="(0,0,1),(1,0,2)"

 

It worked!.

But I tried to run 4 core - 2 Port, 2 queues per port:


l3fwd -c 0xF -n 1 -- -p 0x3 -P --config="(0,0,0),(0,1,1),(1,0,2),(1,1,3)"
EAL: Detected 4 lcore(s)
EAL: DPAA Bus Detected
EAL: Probing VFIO support...
EAL: VFIO support initialized
PMD: net: dpaa: fm1-mac3: 00:04:9f:05:5b:76
PMD: net: dpaa: fm1-mac4: 00:04:9f:05:5b:77
PMD: net: dpaa: fm1-mac5: 00:04:9f:05:5b:72
PMD: net: dpaa: fm1-mac6: 00:04:9f:05:5b:73
PMD: net: dpaa: fm1-mac9: 00:04:9f:05:5b:75
PMD: net: dpaa: fm1-mac10: 00:04:9f:05:5b:74
PMD: dpaa_sec-6 cryptodev init
PMD: dpaa_sec-7 cryptodev init
PMD: dpaa_sec-8 cryptodev init
PMD: dpaa_sec-9 cryptodev init
L3FWD: Promiscuous mode selected
L3FWD: LPM or EM none selected, default LPM on
Initializing port 0 ... Creating queues: nb_rxq=2 nb_txq=4... EAL: Error - exiting with code: 1
Cause: Cannot configure device: err=-22, port=0
[ 90.652132] USDPAA process leaking 16422 FQIDs
[ 91.096213] USDPAA process leaking 6 CGRIDs

 

 

Does any one know how to fix it?

 

Regards,

Yi-Lin

Attachments

Outcomes