wang liu

H.265 decode,using gstreamer pipeline on IMX8M mini

Discussion created by wang liu on May 9, 2019
Latest reply on May 13, 2019 by Joan Xie

Hi,

I am using gstreamer pipeline to decode H.265 video on imx8m mini board, but I have some problem as follow:

 

gstreamer pipeline:

gst-launch-1.0 -v filesrc location=h265_720p.265 ! qtdemux ! h265parse ! queue ! vpudec ! glimagesink async=false enable-last-sample=false qos=false sync=false

 

issue on the Linux shell:

root@imx8mmevk:/unit_tests/Audio#
root@imx8mmevk:/unit_tests/Audio#
root@imx8mmevk:/unit_tests/Audio# gst-launch-1.0 -v filesrc location=h265_720p.265 ! qtdemux ! h265parse ! queue ! vpudec ! glimagesink async=false enable-last-sample=false qos=false sync=false
Setting pipeline to PAUSED ...
====== VPUDEC: 4.4.4 build on May 6 2019 06:48:28. ======
wrapper: 3.0.0 (VPUWRAPPER_ARM64_LINUX Build on Apr 24 2019 05:16:41)
vpulib: 1.1.1
firmware: 1.1.1.0
Pipeline is PREROLLED ...
Got context from element 'sink': gst.gl.GLDisplay=context, gst.gl.GLDisplay=(GstGLDisplay)"\(GstGLDisplayWayland\)\ gldisplaywayland0";
ERROR: from element /GstPipeline:pipeline0/GstQTDemux:qtdemux0: This file is invalid and cannot be played.
Additional debug info:
../../../git/gst/isomp4/qtdemux.c(750): gst_qtdemux_pull_atom (): /GstPipeline:pipeline0/GstQTDemux:qtdemux0:
atom has bogus size 18446464110561329920
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

 

Could you help me to fix this bug? Thanks.

Outcomes