AnsweredAssumed Answered

Booting error in imx6

Question asked by emmanuel perea on May 4, 2019
Latest reply on May 6, 2019 by emmanuel perea

Hello,

I am working with imx6 dual lite conncectore of digi. I am using a 4.9 kernel builfing with yocto 2.4. It was working fine, I have some issues with display but i could boot and operative system init. Until I made a mistake, I mounted mmcblk0p3 i a folder and I replaced the etc folder with another etc folder that I copied flrom another imx6 board, but before that the second etc folder I copied in a windows system. Plus I umounted and mounted the mmcblk0p1 in /mnt/linux to change a dtb file. After that I restart the board but dont start again I had this uotuputs:

 

EXT4-fs (mmcblk0p3): couldn't mount as ext3 due to feature incompatibilities
EXT4-fs (mmcblk0p3): couldn't mount as ext2 due to feature incompatibilities
EXT4-fs (mmcblk0p3): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:3.
devtmpfs: mounted
Freeing unused kernel memory: 1024K
Starting init: /sbin/init exists but couldn't execute it (error -14)
Starting init: /bin/sh exists but couldn't execute it (error -14)
Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt for guidanc.
CPU0: stopping
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.9.81-dey+g2c6ae4c #2
Hardware name: Freescale i.MX6 Quad/DualLite (Device Tree)
 

 

---[ end Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt fo.

 

Reading this I think that kernel is initialized and mmcblk0p3 ext4 is monted, but there is an init error for some reason. I tried to boot from tftp but I had the same problem, and I updated kernel and rootfs in the board but I had the same problem.

Any suggestion?

Thanks

Outcomes