AnsweredAssumed Answered

PN7462AU not able to program after a wrong image is burned to it

Question asked by Midhun V R on May 1, 2019
Latest reply on May 15, 2019 by Midhun V R

Hi ,

I was working with PN7462AU OTA referring the document "AN10995
LPC1100 secondary bootloader" application note.I tried porting the secondary bootloader code and flashed the same in its flash location (0x203000).Afterwards I am not able to reprogram the device.I tried mass erase option and all ,but nothing works.

Following message is coming at the console when programming is failed.

 

Executing flash operation 'Program' (Program file into flash: SB_NXP_VER1_99_2.axf) - Thu May 02 12:09:05 IST 2019
Checking MCU info...
Scanning for targets...
Executing flash action...
MCUXpresso IDE RedlinkMulti Driver v10.2 (Jul 25 2018 11:25:37 - crt_emu_cm_redlink.exe build 555)
( 0) Reading remote configuration
Wc(03). No cache support.
( 5) Remote configuration complete
Reconnected to existing link server
Connecting to probe 2 core 0:0 (using server started externally) gave 'OK'
============= SCRIPT: PN7xxxxx_Connect.scp =============
DpID = 0BB11477
APID = 0x04770021
============= END SCRIPT ===============================
Probe Firmware: LPC-LINK2 CMSIS-DAP V5.183 (NXP Semiconductors)
Serial Number: I3F2E0AS
VID:PID: 1FC9:0090
USB Path: \\?\hid#vid_1fc9&pid_0090&mi_00#8&223a6166&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0:0 after searching for a good core
( 30) Emulator Connected

failed to read DAP STAT register - Nn(05). Wire ACK Fault in DAP access
connection failed - Nn(05). Wire ACK Fault in DAP access.. Retrying
probe 2 TAP 0:0 failed to read TAP ID - Nn(05). Wire ACK Fault in DAP access
Failed on connect: Nn(05). Wire ACK Fault in DAP access
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000C20. Info: <None>
Last stub error 0: OK
Last sticky error: 0x10 POWER AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
(100) Target Connection Failed
error closing down debug session - Nn(05). Wire ACK Fault in DAP access
Unable to perform operation!
Command failed with exit code 1

 

 

I guess something may be wrong with the firmware ,but issue is I am not able to reprogram it. Can anyone help me in this ? 

 

Thanks,

Midhun

Outcomes