AnsweredAssumed Answered

How to program lpc54005 via batch?

Question asked by Alexander Mantel on Apr 18, 2019
Latest reply on Apr 19, 2019 by ZhangJennie

Hello,

I need to flash LCP54005 devices with an LPC-Link by a Batch Script.

I use MCUXpresso IDE v10.3.1 [Build 2233]. WIndows

----------------------------------------------------

I connect to programmer with these orders:

set MCUX_IDE_BIN=D:\Programme\MCUXpressoIDE_10.3.1_2233
call %MCUX_IDE_BIN%\ide\binaries\Scripts\bootLPCXpresso.cmd hid

----------------------------------------------------

I’ve got the orders from the GUI Flash Tool  ->Preview command:

set MCUX_WORKSPACE_LOC=D:/MCUX_WorkSpace_10.3
set MCUX_FLASH_DIR=D:/MCUX_WorkSpace_10.3/.mcuxpressoide_packages_support/LPC54005_support/Flash
set MCUX_IDE_BIN=D:/Programme/MCUXpressoIDE_10.3.1_2233/ide/plugins/com.nxp.mcuxpresso.tools.bin.win32_10.3.1.201902111813/binaries/

%MCUX_IDE_BIN%/crt_emu_cm_redlink --flash-load-exec %MCUX_WORKSPACE_LOC%/LPC54005_Project/Debug/LPC54005_Project.axf" -p LPC54005 --flash-driver= -x %MCUX_WORKSPACE_LOC%/LPC54005_Project/Debug --flash-dir %MCUX_WORKSPACE_LOC%/.mcuxpressoide_packages_support/LPC54005_support/Flash

----------------------------------------------------

The Problem: Red link server must be started over the MCU IDE. Otherwise it doesn’t work and I get this error massage.  

Ns: MCUXpresso IDE RedlinkMulti Driver v10.3 (Feb  7 2019 22:50:02 - crt_emu_cm_redlink build 760)
Wc(03). No cache support.
Nc: Found chip XML file in D:/MCUX_WorkSpace_10.3/LPC54005_Project/Debug\LPC54005.xml
Ns: redlink server client - failed to receive response (to op 26) from server after 2000ms - Unknown error (rc 138)
Nc: Server OK but no connection to probe 0 core -2(ANY) (after 3 attempts) - Ee(42). Could not connect to core.
Ed:02: Failed on connect: Ee(42). Could not connect to core.
Et:31: No connection to chip's debug port

 

Is there a way to program LPC54005 via Batch without starting MCU IDE?

Outcomes