AnsweredAssumed Answered

GPIO Toggling Issue in i.MX8 DX6 Board.

Question asked by Anjalik Krishna on Apr 17, 2019
Latest reply on May 7, 2019 by igorpadykov

Hi ,

       I am working on i.MX8 DX6 board where I am facing issue in toggling few GPIOs from GPIO 0 bank such as GPIO_04 , GPIO_05 , GPIO_07 . I have tried changing the drive strength of the GPIO's in pad settings but that did not solve the issue.

   When the GPIO's are made to toggle from the uboot, the data register of the corresponding GPIO's are getting reflected with the updated value but the GPIO's are in their default state when probed .

      I tried to configure the pads in the  SC firmware code and tried to toggle  the GPIOs. But the Issue persists.

Only these three GPIOs are not being able to control through software and the other GPIO's in the same bank are toggling.

 

And interesting part is ,in i.MX8QXP board , these  three GPIO's are working fine .

 

Attaching the CRO captured images of GPIO_4 toggling in  QXP and DX6  board.

 

 

Any one faced similar issue in i.MX8 DX6 board.?

 

Any help would be appreciated

Attachments

Outcomes