AnsweredAssumed Answered

TWR-KV58F220M Quick Start Guide

Question asked by Steven Ha on Apr 15, 2019
Latest reply on Apr 17, 2019 by Steven Ha

Hi everyone,

 

I've been going through the quick start guide for the TWR-KV58F220M and I'm currently stuck on step 5 where I have to program the board over OpenSDA.

Currently I've downloaded and installed:

  • MCUXpresso IDE
  • mbed serial drivers
  • TWR-KV58F220M SDK
  • FreeMaster 2.0

 

I've also verified that the jumpers are correct.

 

The issue is that when I plug the board into my laptop it doesn't appear as a MBED Drive and the virtual COM Port isn't created. But the LED blinks when I tilt the board so I know that the MCU is working and is running the demo code. I've tried going through the OpenSDA documentation and I've found that my bootlader doesn't match what is shown in the documentation (Figure 2).

                               Screenshot of bootloader drive for my TWR-KV58220M Board

                                                  Figure 1. Bootloader from my TWR-KV58220M board

                                          

                                           Figure 2. Bootloader shown in the OpenSDA documentation 

I've tried copying bootloader files for J-link and the default Open SDA but to no avail. Any insight into my problem would be appreciated. Also I should be able to get around this issue by using a compatible programmer right?

 

Thanks

Outcomes