AnsweredAssumed Answered

errors occurs when support xfde on i.max8m yocto project

Question asked by Wen Fu on Apr 12, 2019
Latest reply on Apr 28, 2019 by Rita Wang
Hello everyone
I'm adding xfde to the i.max8m yocto project.
Here the steps I did:
1, let the bblayer.conf know meta-lxde
     BBLAYERS += " ${BSPDIR}/sources/meta-xfde "
2, add packagegroup to fsl-image-qt5-validation-imx.bb
     IMAGE_INSTALL += " \
     ${QT5_IMAGE_INSTALL} \
     packagegroupe-xfde-base \
3,then bitbake
    DISTRO=fsl-imx-xwayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-xwayland

    bitbake fsl-image-qt5-validation-imx

$ bitbake fsl-image-qt5-validation-imx
Loading cache: 100% |##########################################################################################################################################| Time: 0:00:00
Loaded 3562 entries from dependency cache.
Parsing recipes: 100% |########################################################################################################################################| Time: 0:00:02
Parsing of 2645 .bb files complete (2644 cached, 1 parsed). 3563 targets, 223 skipped, 7 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'packagegroupe-xfde-base' (but /home/david/disk2/imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/dynamic-layers/qt5-layer/recipes-fsl/images/fsl-image-qt5-validation-imx.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'packagegroupe-xfde-base' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['packagegroupe-xfde-base']
ERROR: Required build target 'fsl-image-qt5-validation-imx' has no buildable providers.
Missing or unbuildable dependency chain was: ['fsl-image-qt5-validation-imx', 'packagegroupe-xfde-base']

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Outcomes