AnsweredAssumed Answered

Phy-less 1Gbps ethernet at LS2088A

Question asked by ivan e on Apr 11, 2019
Latest reply on Apr 12, 2019 by ivan e

Hi.

I am using Ethernet at LS2088A connected directly to FPGA. Without PHY.
And i have some issues.

MAC-layer works on 10Mbps while PCS-layer works on 1Gbps.

Linux on LS2088 detects link from FPGA and vice versa. But packets can't go through the channel. At FPGA's side i can see idles at 1Gbps, but every byte of packet "longs" 100 tics(according to 10mbps). Also when i'm trying to enable loopback at LS2088A's serdes - i'm getting packets. But it accepts packets at 10Mbps speed.
Ethtool says that interface works on 1Gbps:

Settings for eth2:
        Supported ports: [ ]
        Supported link modes:   Not reported
        Supported pause frame use: No
        Supports auto-negotiation: No
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Link detected: yes

I can't change "port" setting. I was trying different versions of Linux kernel. The latest one is 4.19.26.

According to MAC driver it's ussing 1000-FD mode by default:

struct fixed_phy_status status = {
.link = 1,
/* fixed-phys don't support 10Gbps speed for now */
.speed = 1000,
.duplex = 1,

};

Could you tell me how to set up channel properly. Tried many OS settings and SerDes registers. Thanks

Outcomes