AnsweredAssumed Answered

I cannot get nodejs latest version - imx6ulevk

Question asked by Gaston Bassi on Apr 4, 2019

Hello,

 

The repo approved by nxp in the Yocto manual documentation is not the latest one (master branch), but th rocko one. Why is this?

 

In OpenEmbedded Layer Index:

 

Checking rocko or master branch, it is only available version 7.10.0 for meta-nodejs (OpenEmbedded Layer Index - meta-nodejs )

 

In OpenEmbedded  Recipes Index:

 

  • For rocko: v8.4.0
  • For master branch: v10.15.3

 

Also, in recipes, there is no npm package and I need that too.

 

So, my questions are:

 

  1. Why the latest branch suggested by i.MX_Yocto_Project_User's_Guide is not the latest one? It repo sync brings rocko.
  2. Should I repo sync the master? How do I do that?
  3. How can I get latest npm as well? (v6.x.x) The layer meta-nodejs includes nodejs-npm as a package but it is not in the latest version.

 

Thanks

Outcomes