AnsweredAssumed Answered

How to set environment for hdmi display.

Question asked by Sujay S on Apr 3, 2019
Latest reply on Apr 4, 2019 by igorpadykov

I'm using iMX6dl sabresd board and booting from sd card (sd3).

I downloaded the mfg tool from the NXP website (i.MX Software | NXP ) and used it to flash images into sdcard.

Version of mfg tool is: i.MX 6 Series Manufacturing Toolkit for Linux 3.14.28 Release .

 

I booted after appropriately changing bootswitch to boot mode.

 

The display(22 inch LED monitor) is connected to the board via HDMI. 

However I'm not getting the open embedded logo on the screen. 

 

 

the u-boot environment (using pri) is:

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------- 

baudrate=115200
boot_fdt=try
bootcmd=mmc dev ${mmcdev};if mmc rescan; then if run loadbootscript; then run bootscript; else if run loadimage; then run mmcboot; else run ni
bootcmd_mfg=run mfgtool_args;bootz ${loadaddr} ${initrd_addr} ${fdt_addr};
bootdelay=1
bootscript=echo Running bootscript from mmc ...; source
console=ttymxc0
ethact=FEC
ethaddr=00:04:9f:03:cf:03
ethprime=FEC
fdt_addr=0x18000000
fdt_file=imx6dl-sabresd.dtb
fdt_high=0xffffffff
image=zImage
initrd_addr=0x12C00000
initrd_high=0xffffffff
ip_dyn=yes
loadaddr=0x12000000
loadbootscript=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};
loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}
loadimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}
mfgtool_args=setenv bootargs console=ttymxc0,115200 rdinit=/linuxrc g_mass_storage.stall=0 g_mass_storage.removable=1 g_mass_storage.idVendor
mmcargs=setenv bootargs console=${console},${baudrate} ${smp} root=${mmcroot}
mmcautodetect=yes
mmcboot=echo Booting from mmc ...; run mmcargs; if test ${boot_fdt} = yes || test ${boot_fdt} = try; then if run loadfdt; then bootz ${loadad;
mmcdev=1
mmcpart=1
mmcroot=/dev/mmcblk2p2 rootwait rw
netargs=setenv bootargs console=${console},${baudrate} ${smp} root=/dev/nfs ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp
netboot=echo Booting from net ...; run netargs; if test ${ip_dyn} = yes; then setenv get_cmd dhcp; else setenv get_cmd tftp; fi; ${get_cmd} $;
script=boot.scr
update_sd_firmware=if test ${ip_dyn} = yes; then setenv get_cmd dhcp; else setenv get_cmd tftp; fi; if mmc dev ${mmcdev}; then if ${get_cmd} i

Environment size: 2299/8188 bytes

--------------------------------------------------------------------------------------------------------------------------------------------------------------

 

I've tried using setenv as follows:

   setenv mmcargs 'setenv bootargs ${bootargs} root=/dev/mmcblk3p2 rootwait rw video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24'

 

but kernel doesn't load and only thing printed on the screen is:

Starting Kernel

 

without using above command the kernel loads fine but still when I run vpu test

cd /unit_tests

./mxc_vpu_test.out -D "-i akiyo.mp4 -f 0"

 

no output on the screen.

 

Can someone please tell me what I have to do?

 

Thanks in advance

Sujay.

Outcomes