AnsweredAssumed Answered

Unable to use interrupts inside the PIL simulation block

Question asked by Manuj Agrawal on Apr 2, 2019
Latest reply on Apr 18, 2019 by dumitru-daniel.popa

Hello,

 

I am new to using the MDBT toolbox for S32K144 on matlab for creating applications. I am facing difficulties in using interrupt routines inside the PIL model block (which contains the code to be executed on the microcontroller). Here are the screenshots of my model. I am trying to toggle a LED on UART transmission complete.

 

 

Top Model 

 

PIL Block

 

The error which I get

 

 

The same error is reported even for any other interrupt I have tried to create. Seems like I am unaware of the methodology of using interrupts in PIL simulaiton. 

 

Step size for both models is same (0.01 Sec)

 

To sum up, I want my embedded system to partially run on PC to design and tune my control algorithm while also been connected to microcontroller for sensor interfacing (which uses interrupts; for data acquisition and actuation).

 

I will highly appreciate any help on this issue.

 

dumitru-daniel.popa  Constantin Razvan Chivu Martin Kovar

Outcomes